import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=\\b[MCDXLVI]{1,6}\\b)M{0,4}(?:CM|CD|D?C{0,3})(?:XC|XL|L?X{0,3})(?:IX|IV|V?I{0,3})";
final String string = "Act IX: The End\n"
+ "Act iX: The End\n"
+ "Act Ix: The End\n"
+ "Act ix: The End\n"
+ "Act IX : The End\n"
+ "Act iX : The End\n"
+ "Act Ix : The End\n"
+ "Act ix : The End\n"
+ "i also me\n"
+ "only ii two\n"
+ "the iii three\n"
+ "what about iv\n\n"
+ "I\n"
+ "II\n"
+ "III\n"
+ "IV\n"
+ "V\n"
+ "VI\n"
+ "VII\n"
+ "VIII\n"
+ "IX\n"
+ "X\n"
+ "XI\n"
+ "XII\n"
+ "XIII\n"
+ "XIV\n"
+ "XV\n"
+ "XVI\n"
+ "XVII\n"
+ "XVIII\n"
+ "XIX\n"
+ "XX\n"
+ "XLIV\n"
+ "XLIX\n"
+ "LXXIX\n"
+ "XCIV\n"
+ "XCIX\n"
+ "C\n"
+ "CI\n"
+ "CII\n"
+ "CIII\n"
+ "CIV\n"
+ "CVI\n"
+ "CIX\n"
+ "CD\n"
+ "CM\n"
+ "CC\n"
+ "CCC\n"
+ "D\n"
+ "DC\n"
+ "DCC\n"
+ "DCCC\n"
+ "CX\n"
+ "CXX\n"
+ "CXIX\n"
+ "CMXCIX\n";
final String subst = "\\U$0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}