use strict;
my $str = 'Act IX: The End
Act iX: The End
Act Ix: The End
Act ix: The End
Act IX : The End
Act iX : The End
Act Ix : The End
Act ix : The End
i also me
only ii two
the iii three
what about iv
I
II
III
IV
V
VI
VII
VIII
IX
X
XI
XII
XIII
XIV
XV
XVI
XVII
XVIII
XIX
XX
XLIV
XLIX
LXXIX
XCIV
XCIX
C
CI
CII
CIII
CIV
CVI
CIX
CD
CM
CC
CCC
D
DC
DCC
DCCC
CX
CXX
CXIX
CMXCIX
';
my $regex = qr/(?=\b[MCDXLVI]{1,6}\b)M{0,4}(?:CM|CD|D?C{0,3})(?:XC|XL|L?X{0,3})(?:IX|IV|V?I{0,3})/mip;
my $subst = '\\U$0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";