#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m) #(([0-9A-F]{6})|([0-9a-f]{6}))"
Local $sString = "Hexadecimal color values are supported in all browsers." & @CRLF & _
"A hexadecimal color is specified with: #RRGGBB. RR (red), GG (green) and BB (blue) are" & @CRLF & _
"hexadecimal integers between 00 and FF specifying the intensity of the color." & @CRLF & _
"For example, #0000FF is displayed as blue, because the blue component is set to its" & @CRLF & _
"highest value (FF) and the others are set to 00." & @CRLF & _
"You can use upper case or lower case letters to specify hexadecimal values : #6A95ED" & @CRLF & _
"or #6a95ed." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"12" & @CRLF & _
"12 " & @CRLF & _
"123" & @CRLF & _
"123" & @CRLF & _
"23" & @CRLF & _
"2" & @CRLF & _
"+12" & @CRLF & _
"12" & @CRLF & _
"-1" & @CRLF & _
"1" & @CRLF & _
"-2" & @CRLF & _
"00 00" & @CRLF & _
"+2" & @CRLF & _
"+9" & @CRLF & _
"-7" & @CRLF & _
"+3445"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")