import Foundation
let pattern = ##" #(([0-9A-F]{6})|([0-9a-f]{6}))"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
Hexadecimal color values are supported in all browsers.
A hexadecimal color is specified with: #RRGGBB. RR (red), GG (green) and BB (blue) are
hexadecimal integers between 00 and FF specifying the intensity of the color.
For example, #0000FF is displayed as blue, because the blue component is set to its
highest value (FF) and the others are set to 00.
You can use upper case or lower case letters to specify hexadecimal values : #6A95ED
or #6a95ed.
12
12
123
123
23
2
+12
12
-1
1
-2
00 00
+2
+9
-7
+3445
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)