# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r" #(([0-9A-F]{6})|([0-9a-f]{6}))"
test_str = ("Hexadecimal color values are supported in all browsers.\n"
"A hexadecimal color is specified with: #RRGGBB. RR (red), GG (green) and BB (blue) are\n"
"hexadecimal integers between 00 and FF specifying the intensity of the color.\n"
"For example, #0000FF is displayed as blue, because the blue component is set to its\n"
"highest value (FF) and the others are set to 00.\n"
"You can use upper case or lower case letters to specify hexadecimal values : #6A95ED\n"
"or #6a95ed.\n\n\n"
"12\n"
"12 \n"
"123\n"
"123\n"
"23\n"
"2\n"
"+12\n"
"12\n"
"-1\n"
"1\n"
"-2\n"
"00 00\n"
"+2\n"
"+9\n"
"-7\n"
"+3445")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.