#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https?:\/\/(w{3}\.)?(leitstellenspiel|meldkamerspel|missionchief|missionchief-australia|centro-de-mando|operatorratunkowy|larmcentralen-spelet|operatore112|operateur112|dispetcher112|alarmcentral-spil|nodsentralspillet|operacni-stredisko|112-merkez|jogo-operador112|operador193|dyspetcher101-game|missionchief-japan|jocdispecerat112|missionchief-korea|hatakeskuspeli|dispecerske-centrum)\.(de|com|co\.uk|es|pl|se|it|fr|ru|dk|cz|mx)\/.*$"
Local $sString = "https://www.leitstellenspiel.de/*" & @CRLF & _
"https://leitstellenspiel.de/*" & @CRLF & _
"https://leitstellenspiel.de/*" & @CRLF & _
"http://wwwleitstellenspiel.de/*" & @CRLF & _
"http://leitstellenspiel.de/*" & @CRLF & _
"https://meldkamerspel.nl/*" & @CRLF & _
"https://www.leitstellenspiel.com/*" & @CRLF & _
"http://meldkamerspel.de/*" & @CRLF & _
"http://operatorratunkowy.pl/*" & @CRLF & _
"https://hatakeskuspeli.co.uk/*" & @CRLF & _
"https://missionchief.de/*" & @CRLF & _
"http://missionchief.com/*" & @CRLF & _
"http://leitstellenspiel.jp/*" & @CRLF & _
"leitstellenspiel.de/*"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")