# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^https?:\/\/(w{3}\.)?(leitstellenspiel|meldkamerspel|missionchief|missionchief-australia|centro-de-mando|operatorratunkowy|larmcentralen-spelet|operatore112|operateur112|dispetcher112|alarmcentral-spil|nodsentralspillet|operacni-stredisko|112-merkez|jogo-operador112|operador193|dyspetcher101-game|missionchief-japan|jocdispecerat112|missionchief-korea|hatakeskuspeli|dispecerske-centrum)\.(de|com|co\.uk|es|pl|se|it|fr|ru|dk|cz|mx)\/.*$"
test_str = ("https://www.leitstellenspiel.de/*\n"
"https://leitstellenspiel.de/*\n"
"https://leitstellenspiel.de/*\n"
"http://wwwleitstellenspiel.de/*\n"
"http://leitstellenspiel.de/*\n"
"https://meldkamerspel.nl/*\n"
"https://www.leitstellenspiel.com/*\n"
"http://meldkamerspel.de/*\n"
"http://operatorratunkowy.pl/*\n"
"https://hatakeskuspeli.co.uk/*\n"
"https://missionchief.de/*\n"
"http://missionchief.com/*\n"
"http://leitstellenspiel.jp/*\n"
"leitstellenspiel.de/*")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.