use strict;
my $str = 'https://www.leitstellenspiel.de/*
https://leitstellenspiel.de/*
https://leitstellenspiel.de/*
http://wwwleitstellenspiel.de/*
http://leitstellenspiel.de/*
https://meldkamerspel.nl/*
https://www.leitstellenspiel.com/*
http://meldkamerspel.de/*
http://operatorratunkowy.pl/*
https://hatakeskuspeli.co.uk/*
https://missionchief.de/*
http://missionchief.com/*
http://leitstellenspiel.jp/*
leitstellenspiel.de/*';
my $regex = qr/^https?:\/\/(w{3}\.)?(leitstellenspiel|meldkamerspel|missionchief|missionchief-australia|centro-de-mando|operatorratunkowy|larmcentralen-spelet|operatore112|operateur112|dispetcher112|alarmcentral-spil|nodsentralspillet|operacni-stredisko|112-merkez|jogo-operador112|operador193|dyspetcher101-game|missionchief-japan|jocdispecerat112|missionchief-korea|hatakeskuspeli|dispecerske-centrum)\.(de|com|co\.uk|es|pl|se|it|fr|ru|dk|cz|mx)\/.*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}