$re = '/.*itemprop="(name|acceptedAnswer|suggestedAnswer)".*/m';
$str = '<div itemscope itemtype="http://schema.org/Question">
<h1 itemprop="name">Какое геометрическое тело получается вращением круга вокруг своего диаметра?</h1>
<h2>Варианты ответа:</h2>
<div class="variants">
<div itemprop="acceptedAnswer" itemscope itemtype="http://schema.org/Answer" class="one-fourth correct"><span itemprop="text">шар</span></div>
<div itemprop="suggestedAnswer" itemscope itemtype="http://schema.org/Answer" class="one-fourth"><span itemprop="text">цилиндр</span></div>
<div itemprop="suggestedAnswer" itemscope itemtype="http://schema.org/Answer" class="one-fourth"><span itemprop="text">конус</span></div>
<div itemprop="suggestedAnswer" itemscope itemtype="http://schema.org/Answer" class="one-fourth"><span itemprop="text">пирамида</span></div>
</div>
</div>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);