package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\/[a-z]+\/)(.+?)(?:\/.+)`)
var str = `/this/one/path/to/hdfs`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}