const regex = /(?:\/[a-z]+\/)(.+?)(?:\/.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\\/[a-z]+\\\/)(.+?)(?:\\\/.+)', 'gm')
const str = `/this/one/path/to/hdfs`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);