use strict;
my $str = '/this/one/path/to/hdfs';
my $regex = qr/(?:\/[a-z]+\/)(.+?)(?:\/.+)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";