import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?<!\\.)\\b(?:0|[1-9]\\d{0,2}|[1-3]\\d{3}|4[0-6]\\d{2})\\b(?:\\.\\d+)?)|(?<!\\.)\\b4700(?!\\.)\\b";
final String string = "0\n"
+ "11\n"
+ "222\n"
+ "3333\n"
+ "4444\n"
+ "4700\n"
+ "4701\n"
+ "9999\n"
+ "47000\n"
+ "0000000\n"
+ "49\n"
+ "99\n"
+ "0.11111\n"
+ "000.2122\n"
+ "4700.111111\n"
+ "The 4700\n\n"
+ "01\n"
+ "000.11111\n"
+ ".1111\n"
+ "1.4700\n"
+ ".4700";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}