re = /(?:(?<!\.)\b(?:0|[1-9]\d{0,2}|[1-3]\d{3}|4[0-6]\d{2})\b(?:\.\d+)?)|(?<!\.)\b4700(?!\.)\b/m
str = '0
11
222
3333
4444
4700
4701
9999
47000
0000000
49
99
0.11111
000.2122
4700.111111
The 4700
01
000.11111
.1111
1.4700
.4700'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end