import re
regex = re.compile(r"(?:(?<!\.)\b(?:0|[1-9]\d{0,2}|[1-3]\d{3}|4[0-6]\d{2})\b(?:\.\d+)?)|(?<!\.)\b4700(?!\.)\b", flags=re.MULTILINE)
test_str = ("0\n"
"11\n"
"222\n"
"3333\n"
"4444\n"
"4700\n"
"4701\n"
"9999\n"
"47000\n"
"0000000\n"
"49\n"
"99\n"
"0.11111\n"
"000.2122\n"
"4700.111111\n"
"The 4700\n\n"
"01\n"
"000.11111\n"
".1111\n"
"1.4700\n"
".4700")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")