const regex = /[?&]shop=\K[^=]+(?=&|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[?&]shop=\\K[^=]+(?=&|$)', 'g')
const str = `http://www.nearbynursinghomes.com/innerpage.php?state=CA&city=RIVERSIDE&shop=ALTA VISTA HEALTHCARE & WELLNESS CENTRE&page=4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}