$re = '/[?&]shop=\K[^=]+(?=&|$)/';
$str = 'http://www.nearbynursinghomes.com/innerpage.php?state=CA&city=RIVERSIDE&shop=ALTA VISTA HEALTHCARE & WELLNESS CENTRE&page=4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);