re = /[?&]shop=\K[^=]+(?=&|$)/
str = 'http://www.nearbynursinghomes.com/innerpage.php?state=CA&city=RIVERSIDE&shop=ALTA VISTA HEALTHCARE & WELLNESS CENTRE&page=4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end