using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*)@(?!((google|gmail|yahoo)\.(com|net)))(.*)$";
string input = @"a@google.com
a@yahoo.com
a@yahoo.net
a@mailwizz.com
a@onetwist.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}