re = /^(.*)@(?!((google|gmail|yahoo)\.(com|net)))(.*)$/m
str = 'a@google.com
a@yahoo.com
a@yahoo.net
a@mailwizz.com
a@onetwist.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end