$re = '/^(.*)@(?!((google|gmail|yahoo)\.(com|net)))(.*)$/m';
$str = 'a@google.com
a@yahoo.com
a@yahoo.net
a@mailwizz.com
a@onetwist.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);