package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)^\s*[\S]+(\s[\S]+)+\s*$`)
var str = `James Bond
Alan
Alan Olav Walker
Peter Parker
Peter `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}