$re = '/^\s*[\S]+(\s[\S]+)+\s*$/ms';
$str = 'James Bond
Alan
Alan Olav Walker
Peter Parker
Peter ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);