re = /^\s*[\S]+(\s[\S]+)+\s*$/m
str = 'James Bond
Alan
Alan Olav Walker
Peter Parker
Peter '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end