#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\+[1-9]\d{6,13}$"
Local $sString = "^((\+?\d){7,15})$" & @CRLF & _
"^\+[1-9]\d{6,13}$" & @CRLF & _
"" & @CRLF & _
"-4566111" & @CRLF & _
"-456--5612" & @CRLF & _
"-455-5456" & @CRLF & _
"456-4567" & @CRLF & _
"+1" & @CRLF & _
"0" & @CRLF & _
"+9+233221" & @CRLF & _
"+1123111" & @CRLF & _
"+01234564" & @CRLF & _
"++1123111" & @CRLF & _
"--5465465" & @CRLF & _
"-65465455" & @CRLF & _
"+54551" & @CRLF & _
"+555555" & @CRLF & _
"+5555555" & @CRLF & _
"+111111" & @CRLF & _
"+1111111" & @CRLF & _
"+111111111111111" & @CRLF & _
"+11111111111111" & @CRLF & _
"++456+4564" & @CRLF & _
"0000000" & @CRLF & _
"0000000+" & @CRLF & _
"+0000000" & @CRLF & _
"" & @CRLF & _
"4564511" & @CRLF & _
"46-45"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")