import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\+[1-9]\\d{6,13}$";
final String string = "^((\\+?\\d){7,15})$\n"
+ "^\\+[1-9]\\d{6,13}$\n\n"
+ "-4566111\n"
+ "-456--5612\n"
+ "-455-5456\n"
+ "456-4567\n"
+ "+1\n"
+ "0\n"
+ "+9+233221\n"
+ "+1123111\n"
+ "+01234564\n"
+ "++1123111\n"
+ "--5465465\n"
+ "-65465455\n"
+ "+54551\n"
+ "+555555\n"
+ "+5555555\n"
+ "+111111\n"
+ "+1111111\n"
+ "+111111111111111\n"
+ "+11111111111111\n"
+ "++456+4564\n"
+ "0000000\n"
+ "0000000+\n"
+ "+0000000\n\n"
+ "4564511\n"
+ "46-45";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}