$re = '/^\+[1-9]\d{6,13}$/m';
$str = '^((\\+?\\d){7,15})$
^\\+[1-9]\\d{6,13}$
-4566111
-456--5612
-455-5456
456-4567
+1
0
+9+233221
+1123111
+01234564
++1123111
--5465465
-65465455
+54551
+555555
+5555555
+111111
+1111111
+111111111111111
+11111111111111
++456+4564
0000000
0000000+
+0000000
4564511
46-45';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);