using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[[:alpha:]]+\_[[:alpha:]]+\((([[:digit:]]{1}),([[:digit:]]{4}),([[:digit:]]+)?)\)$";
string input = @"UW_CF(1,2018,1)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}