$re = '/^[[:alpha:]]+\_[[:alpha:]]+\((([[:digit:]]{1}),([[:digit:]]{4}),([[:digit:]]+)?)\)$/m';
$str = 'UW_CF(1,2018,1)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);