# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\{NUMBER(?<format>\:[^\}]*)?\}/{0$1}/gm;t' <<< "ZNK{NUMBER:D10}
ZNK{NUMBER}
ABC-{NUMBER:D10}{NUMBER:D5}{NUMBER}-XYZ"