const regex = /\{NUMBER(?<format>\:[^\}]*)?\}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{NUMBER(?<format>\\:[^\\}]*)?\\}', 'gm')
const str = `ZNK{NUMBER:D10}
ZNK{NUMBER}
ABC-{NUMBER:D10}{NUMBER:D5}{NUMBER}-XYZ`;
const subst = `{0$1}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);