using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[.*?\]";
string input = @"=IF(ISBLANK('[TEST SLA Report Data - 2H 2020 v0.01.xlsx]Data'!$N7),"",'[TEST SLA Report Data - 2H 2020 v0.01.xlsx]Data'!$N7)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}