$re = '/\[.*?\]/m';
$str = '=IF(ISBLANK(\'[TEST SLA Report Data - 2H 2020 v0.01.xlsx]Data\'!$N7),"",\'[TEST SLA Report Data - 2H 2020 v0.01.xlsx]Data\'!$N7)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);