package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[.*?\]`)
var str = `=IF(ISBLANK('[TEST SLA Report Data - 2H 2020 v0.01.xlsx]Data'!$N7),"",'[TEST SLA Report Data - 2H 2020 v0.01.xlsx]Data'!$N7)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}