const regex = /^((?!gulpfile\.js).)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?!gulpfile\\.js).)*$', 'gm')
const str = `D:\\path\\to\\project\\gulpfile.js
~/path/to/project/gulpfile.js
internal/async_hooks.js
fs.js
buffer.js`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}