re = /^((?!gulpfile\.js).)*$/m
str = 'D:\\path\\to\\project\\gulpfile.js
~/path/to/project/gulpfile.js
internal/async_hooks.js
fs.js
buffer.js'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end