$re = '/^((?!gulpfile\.js).)*$/m';
$str = 'D:\\path\\to\\project\\gulpfile.js
~/path/to/project/gulpfile.js
internal/async_hooks.js
fs.js
buffer.js';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);