const regex = /^file *"?([^" ]*)"[\s\S]*?((?:{[\s\S]*?)*?}[\s\S]})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^file *"?([^" ]*)"[\\s\\S]*?((?:{[\\s\\S]*?)*?}[\\s\\S]})', 'gm')
const str = `#############################################################################
# DB substitution file generated by http://github.com/epics-containers/ibek #
#############################################################################
file "\$(IOCSTATS)/db/iocAdminSoft.db" {
pattern
{ "IOC" }
{ "BL01T-EA-TST-02" }
}
file "\$(IOCSTATS)/db/iocAdminScanMon.db" {
pattern
{ "IOC" }
{ "BL01T-EA-TST-02" }
}
file "\$(ADSIMDETECTOR)/db/simDetector.template" {
pattern
{ "P", "R", "PORT", "TIMEOUT", "ADDR" }
{ "BL01T-EA-TST-02", ":DET:", "DET.DET", "1", "0" }
}
file "\$(ADCORE)/db/NDPva.template" {
pattern
{ "NDARRAY_PORT", "ADDR", "SCANRATE", "NDARRAY_ADDR", "ENABLED", "P", "R", "TIMEOUT", "PORT" }
{ "DET.DET", "0", "I/O Intr", "0", "0", "BL01T-EA-TST-02", ":PVA:", "1", "DET.PVA" }
}
file "\$(ADCORE)/db/NDStdArrays.template" {
pattern
{ "NDARRAY_PORT", "FTVL", "ADDR", "SCANRATE", "NELEMENTS", "NDARRAY_ADDR", "ENABLED", "P", "R", "TIMEOUT", "TYPE", "PORT" }
{ "DET.DET", "CHAR", "0", "I/O Intr", "1048576", "0", "0", "BL01T-EA-TST-02", ":ARR:", "1", "Int8", "DET.ARR" }
}
file "simDetector.pvi.template" {
pattern
{ "P", "R" }
{ "BL01T-EA-TST-02", ":DET:" }
}
file "NDPluginPva.pvi.template" {
pattern
{ "P", "R" }
{ "BL01T-EA-TST-02", ":PVA:" }
}
file "NDPluginStdArrays.pvi.template" {
pattern
{ "P", "R" }
{ "BL01T-EA-TST-02", ":ARR:" }
}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}