# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^file *\"?([^\" ]*)\"[\s\S]*?((?:{[\s\S]*?)*?}[\s\S]})"
test_str = ("#############################################################################\n"
"# DB substitution file generated by http://github.com/epics-containers/ibek #\n"
"#############################################################################\n\n"
"file \"$(IOCSTATS)/db/iocAdminSoft.db\" {\n"
"pattern \n"
" { \"IOC\" }\n"
" { \"BL01T-EA-TST-02\" }\n"
"}\n\n"
"file \"$(IOCSTATS)/db/iocAdminScanMon.db\" {\n"
"pattern \n"
" { \"IOC\" }\n"
" { \"BL01T-EA-TST-02\" }\n"
"}\n\n"
"file \"$(ADSIMDETECTOR)/db/simDetector.template\" {\n"
"pattern \n"
" { \"P\", \"R\", \"PORT\", \"TIMEOUT\", \"ADDR\" }\n"
" { \"BL01T-EA-TST-02\", \":DET:\", \"DET.DET\", \"1\", \"0\" }\n"
"}\n\n"
"file \"$(ADCORE)/db/NDPva.template\" {\n"
"pattern \n"
" { \"NDARRAY_PORT\", \"ADDR\", \"SCANRATE\", \"NDARRAY_ADDR\", \"ENABLED\", \"P\", \"R\", \"TIMEOUT\", \"PORT\" }\n"
" { \"DET.DET\", \"0\", \"I/O Intr\", \"0\", \"0\", \"BL01T-EA-TST-02\", \":PVA:\", \"1\", \"DET.PVA\" }\n"
"}\n\n"
"file \"$(ADCORE)/db/NDStdArrays.template\" {\n"
"pattern \n"
" { \"NDARRAY_PORT\", \"FTVL\", \"ADDR\", \"SCANRATE\", \"NELEMENTS\", \"NDARRAY_ADDR\", \"ENABLED\", \"P\", \"R\", \"TIMEOUT\", \"TYPE\", \"PORT\" }\n"
" { \"DET.DET\", \"CHAR\", \"0\", \"I/O Intr\", \"1048576\", \"0\", \"0\", \"BL01T-EA-TST-02\", \":ARR:\", \"1\", \"Int8\", \"DET.ARR\" }\n"
"}\n\n"
"file \"simDetector.pvi.template\" {\n"
"pattern \n"
" { \"P\", \"R\" }\n"
" { \"BL01T-EA-TST-02\", \":DET:\" }\n"
"}\n\n"
"file \"NDPluginPva.pvi.template\" {\n"
"pattern \n"
" { \"P\", \"R\" }\n"
" { \"BL01T-EA-TST-02\", \":PVA:\" }\n"
"}\n\n"
"file \"NDPluginStdArrays.pvi.template\" {\n"
"pattern \n"
" { \"P\", \"R\" }\n"
" { \"BL01T-EA-TST-02\", \":ARR:\" }\n"
"}\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.