import re
regex = re.compile(r"\b(?<number>[\d,]+(?:\.\d+)?)(?<space> ?|&[^;]{2,7};)(?<dimensions>(?:(?<mathjax>\$[^\n\$]+\$)|(?<unit>(?:Y|Z|E|P|T|G|M|k|h|da|d|c|m|µ|n|p|f|a|z|y)?(?:m|g|s|A|K|mol|cd|Hz|N|Pa|J|W|C|V|F|Ω|S|Wb|T|H|lm|lx|Bq|Gy|Sv|kat|l|L))))", flags=re.MULTILINE)
test_str = ("30 $m^2$\n"
"4,000 km\n")
subst = "$<number> $<dimensions>"
result = regex.sub(subst, test_str)
if result:
print(result)