using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""id\"":\""(?<id>[^\""]+)\"",\""category\"":\""(?<category>[^\""]+)\"",\""correlationId\"":(?<correlationId>[^\""]+),\""activityDateTime\"":\""(?<activityDateTime>[^\""]+)";
string input = @"{""@odata.context"":""https://graph.microsoft.com/v1.0/$metadata#auditLogs/directoryAudits"",""value"":[]}
{""@odata.context"":""https://graph.microsoft.com/v1.0/$metadata#auditLogs/directoryAudits"",""value"":[]}
{""@odata.context"":""https://graph.microsoft.com/v1.0/$metadata#auditLogs/directoryAudits"",""value"":[{""id"":""B2Cxx"",""category"":""xxx"",""correlationId"":xxx,""activityDateTime"":""xxx""....},{""id"":""B2Cxx"",""category"":""xxx"",""correlationId"":xxx,""activityDateTime"":""xxx""....},{""id"":""B2Cxx"",""category"":""xxx"",""correlationId"":xxx,""activityDateTime"":""xxx""....}]}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}