import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"id\\\":\\\"(?<id>[^\\\"]+)\\\",\\\"category\\\":\\\"(?<category>[^\\\"]+)\\\",\\\"correlationId\\\":(?<correlationId>[^\\\"]+),\\\"activityDateTime\\\":\\\"(?<activityDateTime>[^\\\"]+)";
final String string = "{\"@odata.context\":\"https://graph.microsoft.com/v1.0/$metadata#auditLogs/directoryAudits\",\"value\":[]}\n"
+ "{\"@odata.context\":\"https://graph.microsoft.com/v1.0/$metadata#auditLogs/directoryAudits\",\"value\":[]}\n"
+ "{\"@odata.context\":\"https://graph.microsoft.com/v1.0/$metadata#auditLogs/directoryAudits\",\"value\":[{\"id\":\"B2Cxx\",\"category\":\"xxx\",\"correlationId\":xxx,\"activityDateTime\":\"xxx\"....},{\"id\":\"B2Cxx\",\"category\":\"xxx\",\"correlationId\":xxx,\"activityDateTime\":\"xxx\"....},{\"id\":\"B2Cxx\",\"category\":\"xxx\",\"correlationId\":xxx,\"activityDateTime\":\"xxx\"....}]}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}