const regex = /\"id\":\"(?<id>[^\"]+)\",\"category\":\"(?<category>[^\"]+)\",\"correlationId\":(?<correlationId>[^\"]+),\"activityDateTime\":\"(?<activityDateTime>[^\"]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\"id\\":\\"(?<id>[^\\"]+)\\",\\"category\\":\\"(?<category>[^\\"]+)\\",\\"correlationId\\":(?<correlationId>[^\\"]+),\\"activityDateTime\\":\\"(?<activityDateTime>[^\\"]+)', 'gm')
const str = `{"@odata.context":"https://graph.microsoft.com/v1.0/\$metadata#auditLogs/directoryAudits","value":[]}
{"@odata.context":"https://graph.microsoft.com/v1.0/\$metadata#auditLogs/directoryAudits","value":[]}
{"@odata.context":"https://graph.microsoft.com/v1.0/\$metadata#auditLogs/directoryAudits","value":[{"id":"B2Cxx","category":"xxx","correlationId":xxx,"activityDateTime":"xxx"....},{"id":"B2Cxx","category":"xxx","correlationId":xxx,"activityDateTime":"xxx"....},{"id":"B2Cxx","category":"xxx","correlationId":xxx,"activityDateTime":"xxx"....}]}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}