import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "asignarValores\\('([^']*)', '([^']*)', '([^']*)', '([^']*)', '([^']*)', '([^']*)', '([^']*)'\\)";
final String string = "asignarValores('agregarDeudaCarroCompra', '12345678', '01', 'INS', '2009', '2', '0')\n"
+ "asignarValores('uno', 'dos', 'tres', 'cuatro', 'cinco', 'seis', 'siete')";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}