$re = '/asignarValores\(\'([^\']*)\', \'([^\']*)\', \'([^\']*)\', \'([^\']*)\', \'([^\']*)\', \'([^\']*)\', \'([^\']*)\'\)/';
$str = 'asignarValores(\'agregarDeudaCarroCompra\', \'12345678\', \'01\', \'INS\', \'2009\', \'2\', \'0\')
asignarValores(\'uno\', \'dos\', \'tres\', \'cuatro\', \'cinco\', \'seis\', \'siete\')';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);