package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9]{11}(-[0-9]{2,5})?`)
var str = `12345678901
12345678901-12
12345678901-12345
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}