$re = '/[0-9]{11}(-[0-9]{2,5})?/m';
$str = '12345678901
12345678901-12
12345678901-12345
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);