re = /[0-9]{11}(-[0-9]{2,5})?/m
str = '12345678901
12345678901-12
12345678901-12345
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end