$re = '/\b(?<!\.)(?:\d[ -]*){5,10}\b/mu';
$str = '12.123456 = no match
Hello John 124567 = match
12345667 = match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);