import re
regex = re.compile(r"\b(?<!\.)(?:\d[ -]*){5,10}\b", flags=re.MULTILINE | re.UNICODE)
test_str = ("12.123456 = no match\n\n"
"Hello John 124567 = match\n\n"
"12345667 = match")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")